Overall performance

I am experiencing quite poor performance on fairly good mid-range pc. i am having about 45 fps with dips to 40 fps. (running on 1920x1080, no matter the graphical setting, meaning same performance on all settings)

PC specs: fx8320 4GHz, 16GB DDR3 RAM, rx 480 8gb, windows 10

Is the performance subject to improve?

http://pastebin.com/MeFvagSh

I’m experiencing about 17 FPS on an AMD Radeon 8750M with 2 GB VRAM. Which sadly doesn’t make the game very playable.

Hi guys,

How are you measuring your frame rates? I’ve tried lots of common hot-keys in game and couldn’t activate a Unity FPS indicator. Thx for your help.

i just added the game to steam, and I am using the steam overlay fps counter.

2 Likes

We’d definitely expect much better performance on both those systems, although I would expect the 8750M to be towards the lower end of that. We’ll definitely be taking a look at this. If you guys can post your logs that would be a good first step. Thanks!

Posted, sorry I didn´t do it in the first place.

Thanks! We’ll take a look at this and do some more testing on AMD cards.

Also getting poor(ish) framerates, on a 1070 - will post more details when I can test later. :slight_smile:

Yeah, I didn’t expect it to run very well, but not as badly. Switching graphics quality to low got FPS up to about 20. I’m happy to run any experiments you might need. :slight_smile:

(I used FRAPS to measure the FPS.)

Yeah, that sounds odd. If you can post logs, that might be a good start.

Thx for the Steam tip!

Unity’s logging is generally the slowest thing happening. If you’re suffering from the Occlusion Culling bug (see the Known Issues post), the game’s going to be logging a load of stuff as a result. Especially if you’re not running from an SSD, this can affect performance fairly drastically.

I’d be interested to see the content of your logfiles (and everyone else’s) and full specs…!

The primary offender in my log seems to be this exception:

NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Component:get_gameObject ()
  at C_ScopeOptics.StartUpdateCoroutine () [0x00000] in <filename unknown>:0 
  at (wrapper delegate-invoke) System.Action:invoke_void__this__ ()
  ...
  at (wrapper delegate-invoke) System.Action:invoke_void__this__ ()
  at vp_FPWeaponShooter.Fire () [0x00000] in <filename unknown>:0 
  at vp_FPWeaponShooter.TryFire () [0x00000] in <filename unknown>:0 
  at vp_FPWeaponShooter.Update () [0x00000] in <filename unknown>:0 

I assume that this is how the game gets choppy if playing for long enough - after the recent session the log file is almost 3MB.

Haven’t tested with today’s update yet - bought the game on 13th and played through over two days.

Overall performance on GeForce 970m is kind of weird - the game is incredibly choppy if ran at 1920x1080 resolution (even on lowest settings), but is almost perfectly fine if ran at 1280x720, one exception being heavy lag when firing the “continuous beam” type weapons (could use a “fewer shaders, please” kind of checkbox in settings?).

Regardless, the game is good fun. The length seems about right, general combat mechanics starting to feel slightly weary by the final few missions (which, due to picking a clockwise route, also happened to be the last few ones available).

Also I’ve been using sniper rifles (both “proper” and “open” scope variants) for the most of the game, but I’m still not sure what exactly the “steady aim” keybind does.

One of the biggest fps hits is the postprocessing effects, these are done per pixel across the whole screen which ends up as 20,736,00 for a 1080p res but only 921,600 for 1280x720. Even though the amount of geometry stays the same your card is having to do nearly 20x the work! if you remove or untick some of the visual fx settings in the gfx options that can help a bit too. (teh lens effects and high bloom for eg). We will look into the other log errors asap ta!

I have recently upgraded my PCs procesor from fx-8320 to i5 7600k and it have fixed all my performance problems. So it would seem taht the game s problem wasnt with the amd gpu but with slow procesor, just to let you know.

I played through the whole game with mostly a sniper rifle, and I almost never used the “hold robot breath” button. The rifle wave isn’t very pronounced, and I found at the most common engagement distance with the reflex sight it wasn’t needed. There’s also no “gasping breath” sound (obv) but that meant that it was hard to tell when it takes effect and when it stops.

I used it a couple of times with the full scope, but I stopped choosing scopes when I found that most of the time the zoom was too great for most distances.

LordTeflonV: did you upgrade your memory/motherboard at the same time? My recent profiling suggests the main bottleneck is actually memory bus speed.

yes I did change cpu motherboard and rams