Problems with 4:3 aspect ratio


#1

I have a 4:3 tube (no, really) which I normally use in 1280x960, although Windows will drive it at up to 2048x1536 (if I don’t mind having my eyes burned out by 60Hz headache-o-vision [1]).

When I start Tolva, it comes up in 1280x960 (hooray) but it’s not clear this is quite working correctly. When I scan something with magnified vision, the scan data is partly cut off on the right-hand side. Every other UI element seems to be correctly positioned, so perhaps this is just an afterthought?

However, the video resolution menu contains the following choices: 1280x720, 1680x1050, 1920x1080, 1920x1200. I’ve read both that the game only shows 16:9 and 16:10 by default and that it tries to show what you’ve actually got, so I’m not sure if that’s expected.

If I select 1280x720 it goes into a letterboxed mode. If I select one of the higher resolutions it stays in 1280x960. If I first increase the desktop resolution it will letterbox one of the higher resolutions. This all seems to be working much as one might hope except inasmuch as I don’t know why the desktop resolution restricts it.

If I start the game with -allowunsupportedaspect, it adds to this list 720x480, only. This is a 3:2 aspect ratio and definitely not what I expected that argument to do.

Having switched into one of the letterboxed resolutions, I can only get back by editing VideoConfigurationData.xml.

The scan data thing is the only thing that (fairly insignificantly) impacts my gameplay but it seems in general this is not what I would expect the game to do on a machine with a 4:3 display, and as I understand it 4:3 is intended to be supported.

[1] Unlike on an LCD, 60Hz on a tube gives a flicker which some people find extremely unpleasant.


#2

Thanks for the report. There are a couple of things going on here…

Regarding the binoculars: We tweaked the layout for the binoculars to fix an issue on wider aspect ratios, and it looks like that must have broken 4:3 without us noticing. I’ll add that to our buglist and get it looked at for a patch.

The list of resolutions you see in the video menu are those that Unity reports as available on your system (filtered by aspect ratio). Unfortunately if Unity’s not detecting these correctly, there’s not much we can do to fix the list. However, there’s a simple workaround, which is that we’ll ignore the resolution set in the options if you provide one at the command-line.

Unity games support commandline arguments -screen-width and -screen-height by default. This means that you could set your Steam launch options to -screen-width 1280 -screen-height 960 (or use this at the commandline) in order to force the resolution you want.

I hope that helps, and please keep an eye on future patch notes for a fix!


#3

Thanks in advance for the binocs fix.

That’s a bit odd re the video menu; other Unity games (frex KSP) don’t seem to have this issue. I could post an output log if that would help.

Thanks for the suggestion re launch options. (I don’t use Steam, but that’s besides the point - easy to edit the shortcut).