Steam Controller not working correctly


#1

I’m wondering if anyone else is having this problem and knows a fix? I’m on a Steam Link connected by ethernet to a Mac Pro 2013, AMD Firepro graphics cards, running OS X High Sierra. Controller doesn’t work at all unless I switch the game video graphics to windowed 1920x1080 mode. When I do it only acts as a mouse. I tried a community configuration and it still behaved the same way. Any suggestions? Thanks.

JB


#2

Not tried on a Link, but the SC works for me on Win 10. Native SC support would be a boon though, if it were to be patched in. Did you try the controller playing directly on your Mac?


#3

Howdy, thanks for getting back to me so promptly! I will try the controller directly on the computer tonight. I believe I saw a comment somewhere about this whole Steam Link thing but I unfortunately don’t recall where. I know that Steam Controller plus Mac for a small dev is a bit of an outlier to work on and all. I actually connected with folks at Larian for Divinity once to do controller testing for them because they only had one guy tinkering with it on the side! Figured it out though through some sort of controller tester app, totally outside of my wheelhouse but it was fun to help.

I’ll keep you posted. Excited to play!

Thanks


#4

Hi! I’m currently looking into some recent regressions on Linux input which would probably include the problems you’re talking about. I don’t have a fix yet but please rest assured it’s being looked at!


#5

Hey all, I just plugged it directly into my Mac and sadly it’s a no go.


#6

Hi Dan, I’m just wondering if there’s any update on this. Thanks again.


#7

We’re testing a patch at the moment that’s fixed some issues with the controller support. I haven’t tried the specific setup you mentioned, so thanks for the reminder - I’ll look into it this week. Hopefully the patch will be ready in the next week or so, but we’ve had a few gremlins to deal with…!


#8

Thanks for being on top of this! Really appreciated. Keep me posted.